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Introduction 
Your PowerKey Pro keypad is preconfigured from the factory.  This includes the LED and 
backlighting, as well as button assignments.   
 
The buttons can be moved or replaced.  Depending upon how the keypad has been wired for 
signal output to attached devices, the following applies: 

• If you wish to replace button functionality with another device that is not already assigned 
on a keypad, validation of the wiring for that device will be necessary.  Once complete, 
continue with this guide. 

 
An example of this scenario would be a pre-installed keypad and you wish to replace a 
button assigned to a starboard light to a bilge pump, where the bilge pump is not assigned 
to any keypad. 

 

• If you are moving functionality from an existing button to another on the keypad, continue 
with this guide. 

 
An example is when two already assigned buttons exist on the keypad.  In this instance, 
you simply move the inserts and reprogram, or ‘swap’, the buttons. 

 

General Assumptions 
A general technical knowledge of electronics, wiring specifications and programming/software is 
expected.   

 

Software Requirements 
The following is required and must be installed/available prior to installing this software. 

Operating System: Windows XP; Vista; Windows 7  
Memory/RAM:  512K, minimum 
Monitor:  SVGA or better 
Network:  An existing and connected Internet connection 
Comm. Port:  USB 
Comm. Device:  KVaser CAN USB device (KVaser Leaf Light HS suggested) 
   (http://www.kvaser.com) 
CAN Driver:  KVaser CAN driver(s) 
Supporting Software: Microsoft .Net Framework, version 2.  This will be downloaded 

and installed (in addition to any other .Net version already 
existing on your computer) as part of the setup process if it is not 
already available on your computer. 
 
Adobe Acrobat Reader (version 7 or newer) 
 

Other:   Valid email address 
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PowerKey Pro Configuration Manager Installation 
 

The KVaser USB Driver(s) MUST be installed  
prior to installation of this application 

 
1. Obtain the installation file as noted on your registration document sent to you upon purchase of the 

PowerKey Pro Configuration Manager (CAN) software.  Your registration information will be 
necessary to complete the installation. 

 
2. Verify your internet connection is active – the registration process cannot be completed with out it. 

 
3. Double-click the setup.exe file to begin installation. 

 
4. Accept the default installation location to assure future upgrades complete successfully. 

 
5. Complete the installation by following the provided prompts. 

 
 

First Use 
1. Launch the application from your Start menu 
 
2. Accept the End-User License Agreement  

 
3. Complete the registration information as provided you upon your purchase of the PowerKey Pro 

product 
 

4. The application is now ready to connect to your PowerKey Pro device. 
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Main Screen  
The sections of the application’s main form is described below. 

 
 
PK Pro Button 1-8 
This area represents the current keypad configuration.  The smaller numbers in the top right of each colored 
square, as shown, represent the physical button on the PowerKey Pro key pad.  The configuration of this 
area is what is saved to the keypad or to a file, including the Keypad Address of the device.  The available 
addresses are listed later in this document. 
 
The configuration of this section is modified by dragging and dropping the key labels form the Key Selection.  
Each button must have a label for the configuration to be saved. 
 

Key Selection 
The numbered labels in this area control the button function when selected on the key pad.  Drag & drop the 
desired label to modify the button configuration described above. 
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Application Messages 
Certain activity and use of the keypad will generate information that is displayed in the large text box.  This 
information can be saved and is  saved only to a pre-defined location.  The messages listed include a 
successful connection, keypad configuration and other potentially helpful information for later use or 
technical support. 
 
The Save Messages button will save the contents of the window to a file in a pre-determined location.  
Access to this file from C:\Program Files\DSS\PKPro\CM\CAN\Log. 
 
Use of the Clear Messages button only removes the content from the messages text box.  This button does 
not clear or remove/delete the saved messages. 
 

CAN Interface 
Clicking the Connect to CAN button will attempt to establish communications to your installed KVaser CAN 
device, generally the USB Leaf Light device.  This is the first of two actions required to complete 
communications with the PowerKey Pro keypad.  A successful connection message will be shown in the 
Application Messages text box. 
 
Conversely, the Disconnect from CAN button disables communication to your KVaser USB Leaf Light 
device, and the PowerKey Pro keypad.  A message indicating the disconnection will be provided in the 
Application Messages text box. 
 

PowerKey Pro Communication 
Once a successful connection to your USB CAN device has been made, the Read Keypad Configuration 
button will become enabled and allowed to be clicked on, which will quickly read the current PowerKey Pro 
keypad configuration.  Once the configuration is retrieved from the device, the PK Pro Button 1-8 section will 
reflect the device settings. 
 
Use the Write Current Configuration to Keypad button to save the current configuration as shown in the PK 
Pro Button 108 section.  Saving the currently displayed configuration to the device is permanent ; any 
configuration  previously saved to the keypad will be overwritten and can not be retrieved. 
 

Product Messages 
This section will display any messages from Digital Switching Systems about the use of your PowerKey Pro 
keypad.  Information may include updates that are available, known issue resolutions and other similar 
information. 
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Quick Start Guide 
1. Attach the PowerKey Pro Keypad as shown in Appendix B. 

 
2. Launch the application from your Start menu 

 
3. Click “Connect to CAN” button; A successful connection message will be provided in the 

Application Messages section and also the Device Connected text box below this button. 
 

4. Click “Read Keypad Configuration” 
 

5. Assign or Swap buttons: 
A. Drag & Drop the source button from the “Key Selection” area onto the desired 

button shown in the PK Pro Button 1-8 area. 
 

B. Repeat step A to assign additional buttons. 
 

6. Click “Write Current Configuration to Keypad” to save the configuration to the device. 
 

7. Click “Disconnect from CAN” button. 
 

8. Select “Exit” from the “File” menu. 
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Application Use 
The following topics present information for general use of the software for configuration of the 
DSS PowerKey Pro keypad product line. 
 
Be certain that your PowerKey Pro keypad is setup and connected to your computer via the 
KVaser USB device as shown in Appendix B.   

 
Keypad configuration 
Keys are assigned functions based on the smaller numeric key selection icon when dropped on to 
the larger button icon. 
 
Perform this by clicking your mouse button and holding it down on a desired key selection icon 
and dragging it to the left.  When your mouse pointer is over the desired button, release your 
mouse to complete the button assignment. 
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Load a Configuration File 
This application includes a standard configuration file (default.xml).   
 
From the menu bar, select File -> Load Config.  Navigate to the location of the default 
configuration file or previously saved configuration file.  Select the desired file. 
 

Save a Configuration File 
Any configuration created with the application can be saved for later use.  From the menu bar, 
select File -> Save Config.  Navigate to the location you wish to save the file. 
 

Change Options 
Options specific to the use of the application are added from time to time.  From the menu bar, 
select Edit -> Options.  Select or de-select the options desired to enhance your use of the 
application.  Click the appropriate button provided to continue. 
 
Most options take effect upon being saved and others may require a restart of the application.  
When a restart is required, a notification will be shown with available options. 
 

Accessing this Document 
A copy of this document is provided in PDF format and can be view while using the application.  
From the menu bar, select Help –> Documentation.   
 

Digital Switching Systems website 
Information about your PowerKey Pro keypad is periodically updated on our website.  This 
information includes new features, upgrades to the application and new product releases, as well 
as technical support information. 
 
From the menu bar, select Help -> Website and then the item for the web page desired. 
 

Application registration Information and Technical Support 
This information can be provided by accessing Help -> Registration Information from the menu 
bar. 
 
If requesting assistance from our Technical Support team, you may be requested to send us 
information.  The registration information form contains a button to automate this process for you.  
Do not use this function unless requested. 
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About the application 
Information including version, copyrights and trademarks can be obtained from the Help -> About 
menu bar option. 
 

Application Messages 
Some functions of the application log messages to this section of the configuration window.  
These messages can be saved for later review as to the steps taken to configure a device.  This 
same information can be helpful when requesting technical support.   
 
If you are experiencing problems during the configuration of a connected device, be certain to 
‘Save Messages’ frequently. 
 

Product Messages 
Aside from information made available on our website, this area of the application will provide 
periodically updated product information related to your keypad and the software program.  An 
active Internet connection is required for this to function. 
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Technical Support 
Digital Switching Systems provides support necessary for the operation of the PowerKey Pro 
keypad and PowerKey Pro Configuration Manager software through DNA Group, Inc.   

 

Software 
Technical support for software-related assistance is available Monday through Friday, 9am – 4pm 
eastern, except for standard holidays. 
 
To open a support ticket, please contact us via one of the following methods: 
Email:  sws@digitalswitchingsystems.com 
 
Phone: 919.881.0889 (request PowerKey Pro Configuration Manager software 

support)  
 
Website: http://www.digitalswitchingsystems.com/PowerKeyPro/ 
 
Please provide the following information when sending an email or leaving a message for 
support: 

• Your first and last name 

• At least one contact method (email address, phone number and extension (as 
applicable)) that you can also be at along with the software and PowerKey Pro keypad 

• The best time to contact you 

• A description of the issue 
 
Our goal is to provide you service commensurate to the quality of the PowerKey Pro keypad – 
excellent.  To assure we can continue to deliver this service, please be certain to provide the 
information requested above.  Any omission may delay your service request. 
 

Hardware 
Hardware-related support is available Monday through Friday, 9am – 4pm eastern: 
 
Email:  hws@digitalswitchingsystems.com 
Phone:  919.881.0889 (request PowerKey Pro PRODUCT assistance) 
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Appendix A – Device Addresses 
The PowerKey Pro keypad may be re-assigned to a different address.  The address of the each 
device on a connected network must be unique. 
 
Many installations of the PowerKey Pro keypad will have only one keypad.  Although, in some 
instances their may be several inter-connected keypads.  When this occurs, each keypad must 
have its own address to allow for correct communications. 
 
The following are the allowed addresses, selectable from the “Device Address” dropdown list.  
The selected address will be saved to the PowerKey Pro keypad when writing a configuration to 
the keypad: 

 
21 (factory default) 

22 29 

23 2A 

24 2B 

25 2C 

26 2D 

27 2E 

28 2F 

 
The device address can be changed after a successful connection to the keypad has been made 
and the current configuration has been read. 

 
 
 



 
D I G I T A L  S W I T C H I N G  S Y S T E M S ,  L L C  

 

www.digitalswitchingsystems.com 
Digital Switching Systems, LLC   
Subsidiary of DNA Group, INC. 

Copyright Material © Property of Digital Switching Systems, LLC 
April 2010 13  

PowerKey Pro Configuration Manager (CAN) User Guide 

Appendix B – Sample Device Setup 
 
Equipment Requirements 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
        

12 – 24 Vdc Power Supply 
With Power Harness 

 

Kvaser CAN Harness 

Keypad Harness 
Using Deutsch Connectors 

And 330 Ohm Terminal Resistors 

Deutsch Connector 
PN DT04-4P 
Deutsch Pin Contacts 
#0460-202-16141 

Deutsch Connector 
PN DT06-4S 
Deutsch Socket Terminals 
#0462-201-16141 

Deutsch Connector 
PN DT06-4S 
Deutsch Socket Terminals 
#0462-201-16141 
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Keypad CAN Connector Pin-out 
(Deutsch Connector DT06-4S) 

Pin 2 (TX/RX+) 
WHITE Wire Pin 3 (GND) 

BLACK Wire 

Pin 4 (+12/24VDC) 
RED Wire Pin 1 (TX/RX-) 

BLUE Wire 

Complete Device Setup 

Connection 1:  
     12 Vdc >>>  Keypad Harness  >>> Kvaser CAN Adapter  >>> Computer USB Port 
Connection 2: 
     12 Vdc  >>>  Keypad Harness  >>> Kaypad CAN Connector 
 


